Jump to content


Photo

Semikron Miniskiip Igbt Failures


  • Please log in to reply
2 replies to this topic

#1 saifkap

saifkap

    Junior Member

  • Members
  • PipPip
  • 2 posts

Posted 01 February 2009 - 10:44 AM

Semikron miniSKiip IGBT failures





I had quite a few motor and IGBT failures using Semikron miniSKiip moduls.
After performing several tests I found that the failed moduls were bought from on supplier, while modules bought from another supplier performed well. Does anyone had similar problems?
Obviously the supplier claims I had design problem with my circuit…



#2 marke

marke

    Posting Freak

  • Moderator
  • PipPipPipPipPipPip
  • 2,603 posts
  • Gender:Male
  • Location:Christchurch, New Zealand

Posted 01 February 2009 - 05:36 PM

Hello saifkap

I have not heard of this sort of problem before, but it does sound very unusual that the problem is "supplier" related when the product is presumably the same specification.
It is possible that your design is marginal and performance becomes batch related.

I have come across "cloned" devices where the parts are made to imitate another manufacturer but do not meet their specifications. I have not seen this with the miniSkiip products, but it is possible.

How many parts are you having problems with?
What is the application?

Best regards,
Mark.

#3 NATARAJANKADAYAMRAMAKRISHN

NATARAJANKADAYAMRAMAKRISHN

  • Members
  • Pip
  • 1 posts

Posted 14 June 2009 - 07:22 AM

[quote na




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users