Jump to content
LMPForum

Ac-23 Motor Not Spinning With Curtis 1238 Controller


malebu
 Share

Recommended Posts

I Just finished wiring the motor controller Curtis 1238 with my AC-23 motor and batteries. The batteries are currently at 3.8v each so rating upto 92.4v and 120ah.

 

The Controller status LED is blinking slow yellow and the programmer diagnostics shows all OK but the motor does not spin when the throttle is twisted. I can feel the motor shaft gets stiff when controller is fired up. Otherwise the shaft is free moving so the Motor is definitely getting power.

 

My throttle is a Domino electric throttle with 5 wires, i connected 3 to the controller and left the remaining 2 hanging. I even tried with a three wire 0-5ohm potentiometer but motor is still not spinning.

 

Any thoughts / Ideas / suggestions would be really helpful.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...